Monitor & Agent Management Affected by Microsoft Update

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Jun 25, 2022 - 10:53 UTC

Monitoring

Posted Jun 18, 2022 - 19:07 UTC