Slow performance on Application reports - US Region
Incident Report for ControlUp Status Page
Resolved
This incident has been resolved and performance is back to normal.
Posted Oct 04, 2024 - 02:24 UTC
Investigating
We are currently investigating an issue related to the application data reports for a small number of organizations in the US region. Updates will be made as soon as we have more information to share. Thank you for your patience.
Posted Oct 03, 2024 - 17:22 UTC
This incident affected: US (VDI & DaaS - Reports Data Delays).