DEX Dashboard unavailable
Incident Report for ControlUp Status Page
Resolved
We have identified the root cause and fixed the issue. Access has now been fully restored to DEX.

Sorry for any inconvenience caused.
Posted May 15, 2024 - 10:06 UTC
Investigating
We are currently investigating an issue that is preventing access to the DEX platform. (App.controlup.com)

Sorry for any inconvenience caused.
Posted May 15, 2024 - 09:56 UTC
This incident affected: EMEA (DEX - app.controlup.com - Audit Log Services, DEX - app.controlup.com - Platform Services) and US (DEX - app.controlup.com - Audit Log Services, DEX - app.controlup.com - Platform Services).