DEX degraded loading times - US Region
Incident Report for ControlUp Status Page
Resolved
The issue has been resolved and operations are back to normal operations. Thank you for your patience during this investigation.
Posted Oct 31, 2024 - 00:06 UTC
Investigating
We are currently investigating an issue causing some users in the US region to experience slower-than-usual loading times. Another update will be provided as we learn more. Thank you for your patience.
Posted Oct 30, 2024 - 20:09 UTC
This incident affected: US (DEX - app.controlup.com - Platform Services).