Insights Login Difficulty
Incident Report for ControlUp Status Page
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 18:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2021 - 18:26 UTC
Investigating
We are currently investigating an intermediate login issue to ControlUp Insights.
Posted Sep 07, 2021 - 17:35 UTC
This incident affected: ControlUp Insights (Insights Login).