DEX Platform Access Issues

Incident Report for ControlUp Status Page

Resolved

Microsoft has notified us that the issue has been fully mitigated and we are showing no further networking issues.
Posted Mar 18, 2025 - 19:25 UTC

Monitoring

We are seeing significantly fewer network connection issues and customers who were affected are reporting no further issues with their access. Microsoft has not completely removed the notice from their Azure status page, so we will continue to monitor for a little longer.
Posted Mar 18, 2025 - 19:10 UTC

Identified

Microsoft has identified an issue on Azure US East Region that is causing some intermittent connectivity loss and increased network latency. Microsoft's website notes that they have mitigated the issue by implementing some additional networking resources and their services are starting to recover, but you may still see some issues until everything has fully recovered.
Posted Mar 18, 2025 - 18:03 UTC
This incident affected: EMEA (DEX - app.controlup.com - Platform Services) and US (DEX - app.controlup.com - Platform Services).