Insights data delay - NA region
Incident Report for ControlUp Status Page
Resolved
The issue was identified and resolved late October 7. We have confirmed the resolution and will continue to monitor while data catches up in the next few hours. Thanks for your patience.
Posted Oct 09, 2023 - 02:33 UTC
Investigating
We are currently experiencing data delays with organizations in our North American data center. The data team is already investigating and we will provide another update when we know more.
Posted Oct 06, 2023 - 14:44 UTC