DEX Platform performance issues
Incident Report for ControlUp Status Page
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 21:15 UTC
Monitoring
We have found the issue and have deployed a fix. We are monitoring the results. Those affected are encouraged to refresh their session and try again.
Posted Nov 27, 2024 - 18:51 UTC
Investigating
We are currently investigating an issue affecting the DEX platform. Some users may be experiencing error messages and long wait times when logging in and navigating. We will provide another update as soon as we learn more. Thank you for your patience.
Posted Nov 27, 2024 - 18:40 UTC
This incident affected: EMEA (DEX - app.controlup.com - Platform Services) and US (DEX - app.controlup.com - Platform Services).