Controlup.app accessibility issues - Remote Control for Unmanaged Devices not accessable.

Incident Report for ControlUp Status Page

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2026 - 09:00 UTC

Investigating

We are currently investigating this issue.
Posted Aug 18, 2026 - 07:57 UTC
This incident affects: Desktop and Apps (US Region, EMEA Region, APAC Region).