Planned DEX Login Maintenance

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Sep 06, 2026 - 11:56 UTC

Monitoring

The scheduled maintenance has been completed.
Posted Sep 06, 2026 - 11:47 UTC

Identified

Scheduled maintenance is currently in progress. We will provide updates as necessary
Posted Sep 06, 2026 - 11:45 UTC

Investigating

We are currently undergoing maintenance on the DEX platform. All services will return to normal at the conclusion of the maintenance window.
Posted Sep 06, 2026 - 11:43 UTC
This incident affected: DEX (US Region, EMEA Region).