There are delays in receiving inbound emails to the controlup.com domain
Incident Report for ControlUp Status Page
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 14:13 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jan 15, 2024 - 08:35 UTC
Identified
We are currently experiencing delays in receiving emails to the controlup.com domain. This may impact the Support team's ability to receive customer updates related to support tickets. We are actively working with Google to address and resolve this issue.
Posted Jan 12, 2024 - 09:22 UTC