DEX Login Incident

Incident Report for ControlUp Status Page

Resolved

The incident has been resolved.
Posted Nov 08, 2025 - 02:46 UTC

Monitoring

The issue was identified, and a fix has been quickly deployed. We are monitoring the results as all services return to normal. Another update will be provided once confirmed.
Posted Nov 08, 2025 - 00:48 UTC

Investigating

We are currently investigating an issue causing some organizations to fail authentication when accessing the DEX platform. We will provide updates as we learn more.
Posted Nov 08, 2025 - 00:20 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region) and Desktop and Apps (US Region, EMEA Region, APAC Region).