Error when accessing device drill down - CU4D

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved. The RCA will be published at the conclusion of the investigation.
Posted Jun 29, 2026 - 22:50 UTC

Monitoring

A workaround has been confirmed and will be distributed accordingly. The permanent fix will be deployed during the next maintenance cycle. We are monitoring the status before closing this incident
Posted Jun 29, 2026 - 21:31 UTC

Identified

The issue has been identified, and a workaround is being validated
Posted Jun 29, 2026 - 14:43 UTC

Investigating

We are currently investigating an issue causing some organizations to encounter an error when drilling into device details from the Devices pane.
Posted Jun 29, 2026 - 13:22 UTC
This incident affected: Desktop and Apps (US Region, EMEA Region, APAC Region).