DEX Access Issue

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved, and all services are back to normal operation.
Posted Mar 13, 2026 - 20:15 UTC

Monitoring

A fix has been implemented, and we are monitoring the results. We will mark the issue resolved once confirmed.
Posted Mar 13, 2026 - 19:41 UTC

Identified

The issue has been identified, and a fix is being implemented. Another update will be provided once a fix is in place.
Posted Mar 13, 2026 - 19:08 UTC

Investigating

We are currently investigating an issue causing issues logging into the DEX platform. We will provide updates as soon as we learn more.
Posted Mar 13, 2026 - 18:19 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region).