VDI platform availability issues

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 17:13 UTC

Monitoring

We identified the issue, and a fix has been implemented. We are monitoring the results.
Posted Apr 21, 2026 - 16:19 UTC

Investigating

We are currently investigating an issue impacting some organizations' ability to access the VDI products. We will provide another update shortly.
Posted Apr 21, 2026 - 15:47 UTC
This incident affected: VDI (US Region, EMEA Region, APAC Region).