The incident has been resolved and services have been restored.
Posted Oct 30, 2025 - 04:51 UTC
Monitoring
All third-party providers have completed fixes, and we are monitoring progress as all systems return to normal operation. Another all-clear update will be provided once we are satisfied with performance.
Posted Oct 30, 2025 - 01:52 UTC
Identified
The third-party providers have identified a potential issue and are issuing a rollback operation that should restore services to functional status. We will continue to monitor the progress and how the impacts affect ControlUp availability and services.
Posted Oct 29, 2025 - 18:07 UTC
Investigating
We are aware of an Azure outage that may be impacting some users' ability to log in to ControlUp when using MFA through Azure resources. Organizations may also experience performance/availability issues within their DEX tenants. We will continue to monitor the situation to ensure all ControlUp services remain available while the complete outage is investigated.
Posted Oct 29, 2025 - 16:55 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region), Desktop and Apps (US Region, EMEA Region, APAC Region), and Compliance (US Region, EMEA Region, APAC Region).