Delays in Insight and Solve Historical Data at EU
Incident Report for ControlUp Status Page
Resolved
The issue has been resolved and data delays have returned to normal. Thank you for your patience.
Posted Sep 06, 2023 - 18:51 UTC
Monitoring
We have identified the issue and successfully implemented the fix. Services have now been restored. Data for some organizations may take a few hours to catch up.
Posted Sep 06, 2023 - 13:53 UTC
Investigating
Dear customer,
We are presently investigating an issue with our historical data upload service. Some EU customers may experience delays in receiving their historical reports.

We will continue to provide updates on this incident as we gather more information.

We appreciate your patience.
Posted Sep 06, 2023 - 10:00 UTC