Desktop and Apps tenant unavailable

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved. We will continue to monitor for any further issues.
Posted Sep 22, 2025 - 11:49 UTC

Monitoring

A fix has been implemented, and we are monitoring the resources.
Posted Sep 22, 2025 - 09:00 UTC

Investigating

We are currently investigating this issue.
Posted Sep 22, 2025 - 08:12 UTC
This incident affected: Desktop and Apps (US Region, EMEA Region, APAC Region).