Degraded performance - backend networking

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved and performance is back to normal.
Posted Oct 21, 2025 - 20:01 UTC

Monitoring

Upon discovering an issue in the backend networking services a fix was immediately deployed. We are monitoring the results as systems return to normal performance.
Posted Oct 21, 2025 - 16:33 UTC

Investigating

We are currently investigating an issue in multiple regions impacting backend networking services. Some organizations may experience degraded performance logging in to the configuration console and performing functions inside the DEX console.
Posted Oct 21, 2025 - 15:43 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region) and VDI (US Region, EMEA Region, APAC Region).