Resolved. We have confirmed the deployed mitigation was successful. All services are now operating normally. We apologize for the inconvenience and appreciate your patience.
Posted Nov 04, 2025 - 00:31 UTC
Monitoring
Mitigation Deployed. We have deployed a fix and are now closely monitoring service stability and recovery. We'll confirm full resolution soon.
Posted Nov 03, 2025 - 19:18 UTC
Identified
We have identified the issue and are collaborating with a 3rd party vendor on a resolution. It appears to be associated with a network load balancing error.
Posted Nov 03, 2025 - 16:58 UTC
Update
We are continuing to investigate this issue and can confirm that, at present, only customers based in the United States may be affected.
We will provide further updates as more information becomes available.
Posted Nov 03, 2025 - 14:38 UTC
Investigating
We are currently investigating an issue affecting the data stream for Monitors