Trigger Email Alerts delayed
Incident Report for ControlUp Status Page
Resolved
The issue with trigger emails has been resolved and operation is back to normal. Thank you for your patience
Posted Nov 21, 2023 - 14:24 UTC
Investigating
We are currently troubleshooting an issue where trigger email alerts are not being delivered promptly. Thank you for your patience
Posted Nov 21, 2023 - 13:24 UTC