App.ControlUp.com - Performance issues

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.

Many thanks.
Posted May 12, 2025 - 10:39 UTC

Investigating

We are currently investigating slow performance in the DEX application, and we will provide updates as we progress.

Many thanks.
Posted May 12, 2025 - 10:05 UTC
This incident affected: EMEA (DEX - app.controlup.com - Platform Services) and US (DEX - app.controlup.com - Platform Services).