Tenant stability issue

Incident Report for ControlUp Status Page

Resolved

This incident is resolved, and all services have returned to normal.
Posted Mar 05, 2026 - 00:31 UTC

Monitoring

The fix has been implemented, and we are monitoring the results as all services return to normal operation.
Posted Mar 04, 2026 - 22:57 UTC

Identified

The issue has been identified. A fix is being worked on and will be implemented as soon as possible.
Posted Mar 04, 2026 - 22:37 UTC

Investigating

We are currently investigating a stability issue that may cause some users to encounter access issues to several static pages in the DEX platform. More information will be shared as we learn more.
Posted Mar 04, 2026 - 22:14 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region), WorkFlow (US Region, EMEA Region, APAC Region), Desktop and Apps (US Region, EMEA Region, APAC Region), and Compliance (US Region, EMEA Region, APAC Region).