Desktops Tenant - US Partial Outage

Incident Report for ControlUp Status Page

Monitoring

A fix has been implemented, and we are monitoring the results as performance returns to normal. We will close this incident after verifying that everything is back to normal operation.
Posted Aug 02, 2026 - 20:04 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Aug 02, 2026 - 18:41 UTC

Investigating

Some organizations in the US region may experience performance and availability issues with their ControlUp Desktops tenants and other areas that depend on these resources. Microsoft Azure support alerted us to performance issues a short time ago, and we confirmed several impacts across the region. They are actively working on restoring access and will share updates with us as they progress. We will provide updates here as we continue to monitor the situation and react accordingly to restore the impacted areas.
Posted Aug 02, 2026 - 17:34 UTC
This incident affects: DEX (US Region), Desktop and Apps (US Region), and Compliance (US Region).