Tenant Unavailable Error

Incident Report for ControlUp Status Page

Resolved

The fix has been confirmed and the incident is resolved.
Posted Oct 17, 2025 - 04:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2025 - 03:44 UTC

Identified

The issue has been identified and a fix is being implemented. Thank you for your patience
Posted Oct 17, 2025 - 03:18 UTC

Investigating

We are currently investigating and issue impacting several organization's ability to access some of the Desktop and Apps products. More information will follow.
Posted Oct 17, 2025 - 02:25 UTC
This incident affected: DEX (US Region, EMEA Region, APAC Region) and Desktop and Apps (US Region, EMEA Region, APAC Region).