Cloudflare outage impacting websites

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:45 UTC

Monitoring

A fix has been implemented, and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all sites are back to normal.
Posted Nov 18, 2025 - 14:59 UTC

Identified

Due to third-party vendor issues with Cloudflare, some public websites and resources may not be steadily available. We are monitoring the situation and will post an update when the issue is confirmed resolved. There is no impact on production services at this time.
Posted Nov 18, 2025 - 14:04 UTC