VDI accessibility issues.

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 22:36 UTC

Monitoring

A fix had been implemented and we are monitoring the status closely.
Posted Jul 26, 2026 - 22:17 UTC

Investigating

We are currently investigating an issue impacting organizations' ability to access the VDI products. We will provide an update shortly.
Posted Jul 26, 2026 - 20:17 UTC
This incident affected: VDI (US Region, EMEA Region, APAC Region).