Workflows unavailable

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 08:51 UTC

Investigating

We are currently investigating an issue with Workflow.
Posted Sep 11, 2025 - 08:36 UTC
This incident affected: WorkFlow (US Region, EMEA Region, APAC Region).