MFA Issue

Incident Report for ControlUp Status Page

Resolved

This incident has been resolved.
Posted Oct 07, 2024 - 09:23 UTC

Investigating

We are currently investigating an issue that is affecting MFA codes not being received
Posted Oct 07, 2024 - 08:38 UTC
This incident affected: EMEA (DEX - app.controlup.com - Platform Services) and US (DEX - app.controlup.com - Platform Services).